0

I have a Whirlpool Gold WDT790SAYM3 that's stopped running a few days ago. When I start a normal cycle w\ high heat it fills for about 30 seconds, then over the next few minutes I hear a few clicks and whirring noises but the motor never kicks in to wash the dishes. After a while it will drain the water and refill, followed by more clicks and whirs. Along the way the detergent dispenser door opens (but nothing else happens). If I let it run through what would be a normal cycle this repeats a few times and the control panel lights up to indicate the wash is complete. Outside of not actually washing the dishes all display lights and timings are consistent with a wash cycle running.

I ran the 1-2-3, 1-2-3, 1-2-3 diagnostic cycle (several times over the last few days!) and the final error code each time is 6-4 - Float Switch Open. When this first started I could nurse it along, getting the wash motor to kick in with a combination of unplugging for a while, running the diagnostic, restarting a cycle, and/or opening and closing the door mid-cycle. Now the wash motor will not start at all. I want to say when this began the wash motor would run briefly during the diagnostic; now the wash motor doesn't run at all.

Does this really sound like a problem with the float switch? Or should I be looking for something else to tell me what's going on?

  • yes you should look for something else because it will be about $300 dollars to replace the motor and it might be older or will mess it up worse – Samuel Cottrell May 14 at 14:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.