0

I am stuck. I want to remove the handle to replace the cartridge.

After removing the index I see what appears to be a flat head screw, but it is not screwable. It won't budge. I can't screw off the whole handle or pry it off. There is no hex key. I have two other sinks with the same setup, and the screws are cleaner and they also are not screwable. It is a mystery!

What is extra annoying is that I am pretty sure that I have taken off the handle before, but really cannot see how at this point. Any ideas are really appreciated![enter image description here]1

  • Seen this question before... – Solar Mike May 3 at 15:33
  • Thanks. Yes, these are related, but that thread doesn't fully answer the question as far as I can tell. It shows how to take the "index" off (which reveals the screw in the picture), but doesn't show what to do next to get to the cartridge. It is this screw type thing inside the handle that needs to be addressed. Am I missing something? – Jdsstack May 3 at 17:57
  • @Jdsstack pretty sure that's just a screw... You could fill that cavity with corrosion remover like CLR or a thread penetrant like PB Blaster or one after the other to see if the screw loosens (let them set for hours). – JPhi1618 May 3 at 18:20
  • Wow, I think that you may be right. I have two other sinks (so a total of 6 handles) and thought that they were all unscrewable because I had tried 4 of the six. But I just tried the last one and it actually worked, ie was able to unscrew. So now how to get out the one that is pretty much stuck? – Jdsstack May 3 at 19:44
0

If you have a good and steady hand, you could try a tap and dye set to extract it. I also bought a more simplified version of a tap and die set from Home Depot not too long ago and it did the trick for me on some really soft metal screws. Here's the link https://www.homedepot.com/p/Ontel-Speed-Out-Speed-Out-Titanium-Screw-Extractor-4-Piece-1000367/303667297

enter image description here

0

Case closed. The screw extractor failed. I got frustrated and just kept drilling and the handle came off. It did make a crack to the inner plastic part of the handle, but that still fit back in. I used a channel lock to unscrew the cartridge, then I pulled it out by hand.

Went to Ace and got a replacement cartridge (it matched one that was labeled as a replacement for American Standard)

Screwed it and tightened with channel lock.

Ace didn't have a screw that matched the one I drilled through exactly so used a screw with a washer inside the handle.

Job done. Mystery solved. The key piece of information was that this was just a screw.

Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.