1

We have a late 1960's Kitchenaid Superba (by Hobart) dishwasher.

Problem: the drain operates continuously, so the dishwasher can never fill with water. (The water comes in, but it's immediately pumped out.)

Never had this problem until I tried one of the cycles that I don't regularly use. As soon as I pushed the button to start it, the problem appeared. Makes me suspect something went wrong in the control unit.

Is there an easy way to tell whether the issue is with the control/timer unit (maybe an electrical issue is keeping the drain gate open?) versus a problem with the drain solenoid/gate itself?

Replacement parts aren't cheap, so I'm hoping to narrow down the problem.

  • Have you opened it up? Have you tried feeding (the correct!) voltage directly to the drain valve solenoids, and so on? Have you tried cranking all the buttons & dials (whatever is available) thru their full range a few times in case there's crud on contacts? – Carl Witthoft Mar 19 at 14:47
  • Thanks for suggesting an approach! My knowledge of this stuff is fairly basic, so I hadn't considered testing the solenoid with an applied voltage. Let me ask this: I assume the drain is 'open' when there's a voltage across the solenoid? That is, the default is 'closed', when no voltage is applied? Or is that an incorrect assumption? [I have tried all the buttons, multiple cycles, etc. So I don't think it's the contacts on the control panel.] – PhilPDX Mar 19 at 17:05
  • I suspect you are correct that the drain is "NC" (normally closed), but it is certainly possible that it's set to NO (normally open) so residual water drains when the machine turns off. – Carl Witthoft Mar 19 at 19:28
  • Ok, so I got out the voltmeter and I think it's the solenoid. No voltage across the solenoid until the drain portion of the cycle, at which point it kicks up to 120V. So, "normal closed". This must be a case of the solenoid not closing properly at rest, correct? Is it possible to open up the solenoid and see if something is preventing it from closing properly? Replacements seem to be about $40, or I could spend a little more and get a decent used dishwasher that may have a lot more life left. But I like my 60's dishwasher! – PhilPDX Mar 20 at 3:05
  • 1
    Got it! Took the solenoid/valve unit off, disconnected the drain hoses, and could visually see some piece of junk was stuck inside, preventing the valve from closing! Piece of glass from some dishware of by a previous owner? No idea. But I got it out, put it all together, and bingo, problem solved. So, it was just a complete, utter coincidence that the first time it stopped working was the same time I tried to run a different cycle. I find that totally bizarre! What a wild goose chase... the problem would have been so much simpler to diagnose if it had happened any other time. – PhilPDX Mar 20 at 4:34
1

Answer is in the comments to the OP, based on suggestions given there.

Summary (but note that I may be calling some things by an incorrect name!):

  • Used a voltmeter to determine the voltage across the solenoid when I hit "cancel/drain" on the control panel. 120V. The solenoid/valve was thus most likely "normal closed".
  • Disconnected the leads to the solenoid and tested it with an applied 120V. Loud click/bang; the solenoid was clearly functional.
  • Reconnected the lead wires to the solenoid, and used the voltmeter to determine that 120V was applied during the drain portion of the cycle, not the fill/wash portion, meaning that the controller unit seemed to be functioning properly.
  • Removed the solenoid/valve unit from the frame/chassis and disconnected the tubes. Upon visual inspection, there was clearly a foreign object stuck inside that was preventing the valve from closing fully.
  • Was able to remove the foreign object, put everything back together, and voila! It worked.

[Note - I'm omitting all the other steps I took, when I was originally suspected that the controller unit was the problem. I still don't know what I did that originally caused that piece of glass to get dislodged from wherever it had been sitting for however many years, and get stuck in the drain valve. But the fact that I tried running a cycle that I had never used before seems to be ... unrelated. Or at least, I can't figure out the relation. It seems to be just a bizarre coincidence.]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.