0

Have a Trane xv80. Recently we have issue in furnace heater. It stops after a few minutes of heat call and fails due to highr limit device failure. I replaced the high limit switch recently. It is closed before heat call and opens as expected in case of overheat. The real problem is blower fan does not start along with heat call and it makes the heat exchanger overheated. The fan is supposed to run 5min hourly. It runs well only when the system is cooled down. Any clue or idea is welcome. Thank you.

  • Welcome to DIYSE. I revised your title to reflect what I think is the actual question. Feel free to re-revise. So you're saying that the fan only runs when at room temperature (during the 5-minute circulation mode), and it sticks when it's hot? Sounds like motor repair or replacement is needed. Fortunately, those furnaces take a standard fan motor that's not too expensive. – isherwood Dec 14 '18 at 14:39
  • @isherwood thankss tor your comment. I think the limit switch does not always trigger blower motor. My blow motor doesnt have contact capacitor but only transformer. Not sure the replacement of transformer will help or not – Yongkee Cho Dec 14 '18 at 21:41
  • @YongkeeCho -- is there 120V at the fan motor when the furnace is firing? – ThreePhaseEel Dec 14 '18 at 23:38
  • @ThreePhaseEel i guess my problem is i don’t know when exactly the motor is supposed to run. According to web, themotor begins to run to blow up the over heat in chamber. The limit switch opens when the chamber is hot but it doesn’t trigger the blow motor. But the heater works well when the blower runs along with induction motor at the beginning. So I am confused what exactly went wrong. – Yongkee Cho Dec 15 '18 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.