0

I have a mid 1970’s G&S furnace. The blower often (but not always) gets stuck in the on mode even when heat isn’t being called for.

The only way to stop it is to unplug the unit. Re-connecting even after several hours does not fix the problem.

It does, however, rarely stop in its own.

I tried removing the thermostat (Honeywell T5) from the wall and it kept running.

The filter was recently changed.

Any ideas?

1

If there is a circuit board with relays, then it sounds like a faulty (broken return spring) fan relay. Other furnaces use a bimetal switch that extends into the heat exchanger. When the furnace warms up, the bimetal arm would bend and make contact for the blower motor. As the furnace cools, the bimetal arm would straighten out and turn off the blower. A replacement would be needed. It is usually located all by itself with 2 or several wires, and removes easily with 1 or 2 screws.

  • Old relays / contactors get pitted and stick some times. If you tap it and it opens you know you have found the problem. On open frame contacts the contacts can be polished, I have diamond files for doing this but have used fine aluminum oxide sand paper 400 grit or finer, I don't use true emery cloth because it used to contain metal not sure if it still does. If the relay is closed and cannot be serviced time to replace it. – Ed Beal Dec 13 '18 at 23:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.