0

I've tried to remove the caps from the faucet so I can replace the washer to stop the drip. Maybe I'm being too careful to not damage the cap because no matter what I do, it's not coming off.

Here's a picture of the faucets picture I don't know what brand they are but other sinks/faucets in the house are Delta so they might be Delta brand faucets.

I tried to hand loosen them, turning counter-clockwise but it didn't budge.

I then tried to use pliers and placed an old rag on top of the cap to try to remove it but that didn't work either. I also tried putting tape on the teeth of the pliers but when the tape started wearing thru, I stopped. I admit I was really paranoid of damaging the caps and didn't use much force.

Can anyone tell me how to remove it and/or if I'm turning it the wrong direction (counter-clockwise)?

  • Are you sure there are no hidden setscrews? Does the top pop off? Gold ring slide up or down? – rdtsc Sep 2 '18 at 1:27
  • @rdtsc, thanks for your comment. It doesn't look like there are set screws. I used my phone to try to show around the knob. The top doesn't seem to pop off, although, same thing, I might have been too gentle for fear of scratching the knob. The gold ring doesn't slide up or down. – Classified Sep 3 '18 at 6:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.