I have trouble removing the cover for this light:

Light_1

Light_2

Light_3

A related link mentioned that one of the claws is spring loaded. However, when I tried pulling on it, it seems to be stuck.

Do I need a special tool?

  • It may be that pushing that tab releases the claw. – Jim Stewart Jul 21 at 16:18
  • I just tried both pulling and pushing the tab. However, it doesn't seem to work for me. – Alertnetone Jul 21 at 16:50
  • Try pulling down to see if that releases the claw. – Jim Stewart Jul 21 at 21:42
  • 1
    the claw should pull straight out of the retainer .... the spring probably pushes into a hole in the claw and you have to overcome the force of the spring – jsotola Jul 21 at 22:42
  • ”...it seems to be stuck” Bingo! – Tyson Jul 21 at 23:29

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.