0

So the thermostatic dial has ceased up and I want to open it to order and replace the cartridge. Trouble is I can't get it open!

What I have done:

Top handle

Unscrewed the nipple with pliars and rag

Unscrewed the hex screw behind it(and it fell in)

Pulled / jimmy'd and twisted but the handle wouldn't come off.

Bottom handle

Removed the screw cover and hex screw which is opposite the nipple

Tried and failed to unscrew the nipple and scratched it a bit (it is sprung loaded so maybe it isn't supposed to unscrew)

Pulled / jimmy'd and twisted but the handle wouldn't come off.

What am I missing?! Am I fighting rust? If I just need more force then how can I do it without damaging the chrome? Thanks for the help!

enter image description here

  • did you check the manufacturer's web site? – jsotola Mar 5 '18 at 3:42
  • @jsotola I don't know who the manufacturer is. – Joe U Mar 5 '18 at 8:19
  • 1
    Have you tried gentle taps on the face of the handle? Like if you were installing it, to try and loosen any buildup of deposits or rust. – Jeff Cates Mar 5 '18 at 14:25
  • @Jeff that worked for the bottom handle but not the top handle. Any other ideas? – Joe U Mar 10 '18 at 14:45
  • Hmm, other than keep trying....maybe try vinegar sprayed up behind the handle, or some WD-40 like penetrating oil. Tap and twist and tap and twist.... – Jeff Cates Mar 10 '18 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.