So I've had a small Ryobi snowblower (40v, 20 in brushless model). Been working fine for a few years now .. but just today I took it out, started it up .. and it immediately stalled. I hadn't yet started hitting snow ... just start it ... wait 2 s, stalls. The "scoops' or whatever you call them are spinning .. (confirmed by having a 2nd person watching from in front) .. both batteries are showing full charged and I've tried both batteries.

I'm not sure what else to check or try ... hoping I don't need a trip to repair shop :)

enter image description here

3 Answers 3


Ok so I was unable to troubleshoot this on my own, and I checked the batteries out a few times, they seemed perfectly fine. So took it into the shop, turns out the problem was a burned out motherboard. Fixed under warranty, so that's good.

Just wanted to post the update here for anyone else encountering similar symptom.

Batteries are fine, no issues with them.



I would try brand new batteries. When Lithium batteries fail they act like this. The on-board electronics that indicate status are not that reliable.


I had the same issues - it would run, then die, then run and die. I took out the battery (which showed 3/4 charged) and fully charged it. Seems to have solved the problem.

  • OP mentioned (6 years ago) that the batteries were already fully charged...
    – FreeMan
    Commented Jan 4 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.