1

UPDATE, MAY HAVE FIXED IT! Going to go get some plumber's grease and grease it up good before I do a full reassemble, but right now the water is no longer pouring out as it does in video above.

Fix: I pulled the cartridge out to try to really examine how it works and see if I could verify that it was pushed in all the way and I noticed that the o-ring on the bottom of the cartridge (stock pic, hotlinked moen cartridge) had a little chunk taken out of it. Thankfully, my old cartridge's bottom o-ring was intact (it was torn higher up on the big black section that has the hole in it) so I swapped the o-rings and then re-sat the cartridge in the hole, making sure it was seated completely.

(Original post) I had a minor leak from base of kitchen sink faucet (the part that turns the faucet on and off, not the actual long-neck spout itself). Read up on it and it seemed that a faulty cartridge was the likely culprit. Bought new cartridge that matched the cartridge I pulled out of it. Did the replacement following directions I found online, which matched the directions that came in the new cartridge package (Moen 1225) I bought, and matched this video.

You can see that at about 4 min in the video, he turns the water back on and pulls up the cartridge to verify that he has his hot/cold settings correct.

Well, when I do that, water pours out of the top of the cartridge and goes EVERYWHERE...

Here's a video of what I mean.

Where did I screw this up? And how do I fix it?

I should mention that when this happened initially I tried putting the old cartridge back in to see if it would go back to the minor leak instead of pouring out water---but the old cartridge now behaves the same way as the new one does... so I'm inclined to think this is user error and not a bad cartridge..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.