1

I have a Goodman furnace from 2000 has been running great until recently it does not seem to cinc with thermostat. when you shut unit down and turn back on it will go through all motions of starting except igniter will not glow. once you shut off and on about 7 times it will then fire up and run but will then shut off once desired temp is hit but will not turn on again, there is also no codes showing. I'm thinking it may be with the thermostat relay switch??

  • What's the model number of the furnace, and the make and model of the thermostat? Do you have a multimeter? Are you comfortable working on live HVAC systems? – Tester101 Dec 29 '17 at 18:54
  • Model # GMP100-4 Rev B thermostat ge cht18-60 3AAT76A21A55 yes and yes – Wayne Dec 30 '17 at 19:39
  • have you checked the continuity/resistance of the hot surface igniter? Have you checked to see if the HSI is getting voltage when it should? If everything else is doing what it should, but the HSI is not glowing. I'd look at the HSI first. – Tester101 Dec 31 '17 at 0:49
  • The problem is why would it glow and ignite sometimes. If it was the HSI I don’t think it would work at all? – Wayne Jan 1 '18 at 1:21
  • could be a bad connection, intermittent problem with the control board, etc... Could be a broken HSI, that still makes contact sometimes. – Tester101 Jan 1 '18 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.