0

I have a Frigidaire dishwasher model FDB1050REC2.

It's been working mostly fine for the last year. (Occasionally it doesn't start, but opening and closing the door and moving the dial to Rinse Only and back to Normal fixed that.)

As of yesterday, it won't start at all — pressing the start button causes the "Washing" LED to flash in approximately one-second intervals.

Things I tried:

  • cutting the power to the dishwasher (via the circuit breaker)
  • after restoring power, put the dial to Rinse only and pressed and held Heat Dry + Start/Cancel. Test mode did not fire.
  • from idle, put the dial to Rinse only and pressed and held Heat Dry + Start/Cancel. Test mode did not fire.
  • removing the front panel, disconnecting the two halves of the wiring harness and reconnecting

I tried cutting the power a few times, from a few seconds to a few minutes.

Documents:

I have a multimeter and other tools.

  • the flashing LED means its driven by a microcontroller, and the micro is not happy. You can check the continuity/lack of physical sensors like the door closed, float, etc, but if none of those are wrong, you're probably looking at replacing it. – dandavis Dec 22 '17 at 6:13
  • I tried replacing the control board — no change. – Paul Schreiber Dec 22 '17 at 18:42
2

The problem turned out to be the door latch. One of the two sets of leads failed a connectivity test. enter image description here

Replacing the latch fixed the problem.

  • 1
    Just wanted to shout out to you for this post. I am having the same issue (see my question here) and was able to identify the problem after reading your post here. – Eddie Kal May 26 at 13:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.