1

I can’t get the icemaker tubing pictured below to snug inside the compression nut. Can tighten but, but tubing keeps slipping out. Any suggestions? enter image description here enter image description here

  • Are you missing the inner compression ring (ferrule)? Disassemble the fitting and take another picture of all the pieces for us, please? – Dotes Dec 8 '17 at 2:27
  • No, I am not missing ferrule. Picture in original posting. – georgia-guy Dec 8 '17 at 2:40
  • You have a ferrule that needs to be replaced. They pretty much are "one shot", as they compress slightly when the nut is tightened. (The ferrule is the round part that you insert the tube thru, you have the self contained version that is attached to the nut---the ferrule is not the barrel piece that slides inside the tube. ) It's normal to have to replace that piece anytime you disconnect the tubing. – Tyson Dec 8 '17 at 3:56
  • @Tyson I don’t know if tubing is not go far enough down in where it is suppose to or not. The ferrule doesn’t seem to want to clamp onto tubing. Is there some alternative to compression nut setup while still using plastic tubing? – georgia-guy Dec 8 '17 at 4:15
  • 1
    I also am not liking the look of the shredded black plastic at the nut/valve location (or the bit inside of the nut). I would say that your inability to tighten the nut enough to compress the ferrule is related to bad threads on the valve where the nut connects. – Jimmy Fix-it Dec 8 '17 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.