0

So my Honeywell non WiFi Thermostat was working fine except for the low battery signal in the top right-hand corner. We took the face off of the thermostat of course shutting the Heat and fan off before doing so replace the batteries and it seems to be working wonderful as far as the lights turning on and all the options working but now the heat will not go on and it is close to 55 degrees in my house and going to do nothing but drop for the rest of the night. Any suggestions? Help me please? Getting cold

  • try turning everything off and back on. – dandavis Nov 18 '17 at 13:08
  • What happens when you jumper R and W at the thermostat base? – ThreePhaseEel Nov 18 '17 at 16:09
  • I tried on and off a few times, no heat – Jason Davis Nov 18 '17 at 19:39
  • Three-phase idk what that means, how do I do it? – Jason Davis Nov 18 '17 at 19:39
  • Are you using rechargeable batteries? They provide about 1.2v, whereas alkalines and lithiums provide about 1.5v. – isherwood May 17 at 13:05
0

Depending on the model there is sometimes a very small reset button that needs to be pushed after the batteries are changed. Usually about 1/16” round. Not all thermostats have this though. It would be under the cover somewhere. I have also had similar problems with cheap batteries particularly Costco Kirkland batteries even brand new. I have never had problems with Duracell or Energizer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.