0

I got a brand new air conditioning unit installed (Mitsubishi MSZ GL60 VGD) about a week ago. We've only used it a handful of times and it worked fine.

However, today I went to turn it on and it didn't respond. Neither input from the remote or button on the condenser worked. The remote's batteries are fine, there are no tripped switches and the power switch is on.

Would anyone know what I could do to trouble shoot this?

3
  • Does the unit have any lights on or are they off? Any indication that the unit has power ? If it has power what temperature is the thermostat set at?
    – Ken
    Oct 10, 2017 at 10:50
  • @Ken No lights on the unit and no indicator that the unit has power (apart from the power switch being on the On position). The one button on the actual condenser unit seems to do nothing either.
    – MeltingDog
    Oct 10, 2017 at 22:13
  • check your circuit breakers in your circuit breaker panel. Wiggle the one associated with your AC unit. If it is tripped or flips to tripped when you wiggle it - reset it. If it occurs again you will need to replace it or resize it for your unit. Since you said you had it installed - the installer should have verified the size of the breaker and installed a proper size (they probably have a clause for additional charge to do that.. check your agreement).
    – Ken
    Oct 11, 2017 at 17:42

1 Answer 1

1

I would call the installer. It's only been a week, you should still be under warranty. You've checked the obvious things.

1
  • the op had not checked the obvious things; simple things would be to know if the unit even has power - regardless of the control panel positions and actions. If a Circuit breaker in his home panel is tripped - calling the installer can easily cost the op some cash. If the breaker is tripped - he can check his contract for installation to see what things are included or cost extra - proper cb sizing should be 230V - 16A .. Manual mitsubishi-electric.com.au/assets/LEG/…
    – Ken
    Oct 11, 2017 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.