my maxipod has worked perfectly well since installed in 2014 but now it has started to put hot water into header tank then out the overflow. I turned of water going out from header tank to maxipod and then hot or should i say luke warm water came out expansion pipe into header tank. NOW i have no hot water or heating what can i do?

  • problem solved i had a combi boiler converted but somehow a pressure balancing pipe with a tap somehow magically open a little putting pressured water into hot tank thanks for comments. – pwm Apr 20 '17 at 11:03
  • please provide and accept your findings as an answer so that the question can be resolved. Take the tour if I'm not making sense. – isherwood Nov 3 '17 at 15:55

Check for internal coil leaks. excess water is being supplied to the maxi-pod from somewhere. Also check with the installing contractor and the manufacturer for the warranty coverage provided. You said " it started to put hot water into the header tank"; what is the header tank? If the header tank is isolated then that part of the system is probably ok. Check for problems elsewhere. My recommendation; if a system is too complex, too new, or too sophisticated, it is probably not a good buy unless it comes with a very good long term warranty including parts and labor. I prefer the older "tried and true" systems. What is the sources of heating to the Maxi-Pod; solar, wood/coal stove, conventional central heating system, etc. Lastly can you isolate the Maxi-Pod and return to the conventional heating system until repairs are completed?

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.