I have a fairly old Peerless, natural gas fired, forced water boiler. It has an electric ignition system (White Rodgers 50E47-843 Universal HSI Ignition Module).

A few weeks ago it shut down (safety lockdown, blinking red light). After I cut and restored electricity to the system it restarted without trouble. But then, a few days later, it locked out. Any time I cycled the power to the system it restarted fine, and would be fine for a few days. I replaced the HSI igniter (glow plug) but that didn't fix it. I am unable to find an exact replacement for the flame sensor.

This morning, it locked out again. When I tried the power-toggle trick the glow plug lit up, as before, but the gas didn't kick in right away; it started after the glow plug stopped glowing.

I have two questions:

  1. Any ideas as to what might be the problem?

  2. If I want to replace the flame sensor, the specified flame sensor is a WR-760-403 which does not seem to exist anymore. The closest thing is the WR-760-401, which differs from the 403 in that it's a straight wire, as opposed to a bent wire in the 403. Can I used the 401? Should I bend it (in a vise, or something) to match the shape of the 403?


A few additional points:

  • I've noticed this tends to happen more often overnight when the thermostat is set lower. However, it does happen at other times and higher thermostat settings, too.
  • Cleaning the flame sensor did not help. I did that this AM, this afternoon when I got home it was in lockdown.
  • This is a new issue; We've been in the house for 3 years without a problem. Nothing changed since last season, or since the beginning of this season.
  • I've only seen the weird timing issue once out of tens of times the power-cycling worked.
  • Have you tried cleaning the flame sensor (using steel wool, or fine sandpaper)? This normally needs to be done yearly. The gas not kicking on at the right time sounds like a totally different problem, but cleaning the flame sensor is easy and cheap and will at the least rule it out.
    – gregmac
    Jan 2, 2012 at 22:39
  • Yes, tried that this AM. No dice. Am updating with further thoughts.
    – Eli Lansey
    Jan 3, 2012 at 0:22

1 Answer 1


I gave in and had a plumber come this AM. He said it was the control module which was broken, and he replaced it.

  • I was experiencing pretty much the same symptoms on my oil furnace this season. I replaced the Honeywell control module also and that fixed the issues.
    – Dave Nay
    Jan 3, 2012 at 16:46
  • One week later, and this seems to have solved the problem.
    – Eli Lansey
    Jan 9, 2012 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.