I have a Magic Chef stove (model: 31203KAW) which is not lighting/igniting. We're using a butane lighter to light the stove-top burners (the gas still flows) but I'm nervous about turning on the oven "just to check" (visions of suicidal housewives are dancing in my head). How do I relight the pilot light... if that's even what I need to do? Help please.

  • I think Michael's answer is a good one: if this is a spark ignition system, there is no pilot and there is (probably) nothing to worry about. Modern stoves do not use pilot lights because of the risk of fire. Pilots are notorious for going out, and leaking gas into the kitchen. While a small amount, it can be dangerous. Modern stoves use sparks to ignite burners, and a glow plug to ignite the oven. If your stove is old enough to have pilot lights and is having issues lighting, then it might be worth investing in a new stove.
    – user4302
    Dec 28, 2011 at 4:40
  • Is this problem particular to the Magic Chef gas range, or do other gas ranges have this same problem?
    – user19967
    Feb 18, 2014 at 10:07
  • thank you there was a pilot in the drawer on the bottom for the oven. your answers saved me a service charge, thank you.
    – user55161
    Jun 13, 2016 at 3:00

4 Answers 4


Do you have the manual for the thing? I've done a little poking around (I even found a bunch of parts diagrams at Sears website), and I'm getting the impression that it's got a spark ignition system, not a pilot. Is the range plugged in? Is there any chance that the circuit it's on has tripped it's breaker? I've got a cooktop with a spark ignition system, and it has a special 'light' setting on the gas control - you turn it to 'light', which turns on the gas and starts the sparker. Once it ignites you turn it further to whatever setting you want. Does yours have anything similar? Does it make a 'clicking' noise when you start the gas?

Also, has it ever worked? If so, when did it stop working? Did you make any changes to the kitchen at that time?

  • yep, Agree. Unless this is a very old range, it should have electronic ignition, one igniter per burner usually. Dec 28, 2011 at 15:12

Courtesy of a Google image search, I found the wiring diagram for your stove (see below).

It shows that your stove-top burners are lit by spark ignitors and that your oven is also run by an electric ignition system. It's most likely that the oven is done with a hot coil resistor. If you look under the oven, you'll see it glowing while you've got a rolling flame next to it.

Just in case somebody does have one that has a pilot light, the complicated part is that pilot light systems come with safety valves. If the flame is out then the gas valve will close because the thermocouple / thermopile won't be generating any electricity to hold it open. You need to find the system that allows you to let gas flow without the flame and hold it open for a few seconds after the flame has started.

stove electronics diagram.


Open the drawer under the oven. Inside towards the back near the center along the top there is a metal prong sticking out - like a mini-sprinkler pipe. At the end of the pipe is something that looks like a sprinkler head. This is where the pilot light is located and where it must be lit. Set the oven's temperature to "Off", remove the stove's oven control knob, and push in on the metal control rod there while holding a lighter under that sprinkler head— this should cause the pilot to light. Hold the control rod in for a few seconds to allow the pilot to warm up the oven's thermocouple, then release it. If the pilot stays lit, you are all set! If not, try again and hold the control rod down longer. All the other answers on here are wrong: lots of stoves in modern apartments still have pilot lights. They are no big deal and are very common and safe except in certain very rare situations. It is true that a lot of new stoves have spark systems but pilot light set-ups are still very common.

  • 2
    Is this in reference to the Magic Chef 31203KAW, or stoves in general? Many of those answering before have been researching which type of ignition system this stove has before posting their answer.
    – BMitch
    Sep 18, 2013 at 21:33

Here's what worked for me. The manual says to push in the oven knob while applying flame to the thermocouple. That hasn't worked so well for me, so following up on someone else's suggestion, I took the knob off and pushed in the control rod while applying flame to the thermocouple. It worked like a charm! Apparently just pushing in on the knob doesn't get the gas flowing to the thermocouple.

Not the answer you're looking for? Browse other questions tagged or ask your own question.