0

I just finished installing a tankless water heater (yay!). Unfortunately, we weren't ready to do a full replumb of the house, so we patched into the pipes connecting the old water heater. For some reason, this house has galvanized plumbing for everything (gas and water). Before replacing the water heater, all water ran as expected. Afterward, I believe we dislodged some of the built-up deposits and now the sink faucet is running slowly.

Is there a good way of dislodging corrosion build-up within galvanized? We'll replumb soon, but having full functionality until then would be nice.

EDIT: Additional information: The hot and cold do not get mixed at the faucet, like a typical faucet. Instead, there are two faucets, one for each the hot and cold. As such, backflushing will take a bit more effort.

Also, I've tried leaving a hot faucet open and closing the tankless hot service valve (effectively closing the hot supply), then switching the service valve back on in an attempt to create a water hammer effect. This did not work after several attempts.

  • The airator is probably plugged with scale, it is possible that large sized pieces are stuck in the valve. Remove the airator and turn the tap on if it flows well clean or replace it. If still low flow try turning of the shut off valve sometimes this will break up stuff stuck in the valve and allow it to flow out. – Ed Beal Feb 22 '17 at 0:26
  • As Ed said, but add to that that you can also disconnect the hose from the valve and make sure it doesn't have a plug, then reattach and unhook from the faucet and flush it out into a bucket, allowing any build up behind the valve to flush out. Only other option, if those don't work, is to shut off water to the house, pull the valve off (if you can) and flush the line if the valve is plugged beyond easy flushing. I have been installing ball valves as I re-do plumbing. A lot easier to flush out and not worry about rust building up. I also have been installing CPVC in place of the old copper. – Jeff Cates Feb 22 '17 at 0:48
  • @EdBeal There is no aerator... The sink in question is a really old school two-faucet wash basin. I'll give a shot at disconnecting the flex line connecting the faucet to the supply. Thankfully someone previously replaced an old hard line with newer stuff... – Hari Ganti Feb 22 '17 at 2:14
  • Don't forget to try closing the supply valve at the wall, another trick if cycling the valve and flushing the flex line Fails turn your hot water supply off open another tap hot water now open the hot water on this sink plug the faucet with your hand and turn on the cold at this sink. I have had this work after several tries it pushes the plug at the valve back and sometimes breaks it up but it may take a few cycles (turning the hot back on and some water hammer from a little air in the lines really helps) if this doesn't work the first time try it 2-3 times it usually works with 2 cycles. – Ed Beal Feb 22 '17 at 2:31
  • I will try that when I get a chance. I'll edit my post to reflect what I've tried as well. – Hari Ganti Feb 22 '17 at 3:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.