1

A while ago I ordered these led strips. Yesterday they arrived and I immediately installed them in my room. Everything worked fine and it looked great. But since just an hour ago something seemed wrong: when I turned them off, the red lights stayed on. After trying different settings I noticed that the red lights are on all the time: I can't turn them off or even dim them. Every color (except red of course) looks different now and to turn them off I literally have to pull the plug.

I don't know what happened. They worked fine, I turned them off yesterday night and today it was broken. I'm guessing it is the poor quality since they were pretty cheap but I'm not sure.

Hopefully someone knows a way to fix this.

Cheers!

  • Have you tried them in a different receptacle? Is the receptacle switched or not? – mmathis Feb 21 '17 at 18:54
  • I have, it didn't make any difference. Sorry for my very slow response. – Dieter Nuytemans Mar 1 '17 at 8:03
1

Exactly. It's a cheap cheese controller, if the price tag wasn't a dead giveaway.

Get another one from anywhere, long as it's

  • your same voltage (almost certainly 12V, some don't even care) and
  • the same number of channels (RGB and RGBW controllers are different).

In fact, I'm now seeing RGB controllers from top tier makers (I can't remember the brand, GE, Siemens, Philips, Sylvania, one of those) - also IKEA makes surprisingly good stuff that performs very well IME, and is top rated by the Youtubers who do teardowns.

  • Alright! Thank you for your quick response. I'm glad it's easy to fix! I'll take a look right away. – Dieter Nuytemans Feb 21 '17 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.