0

I have a ceiling fan that has a remote. The fan speed control works on fan and the switch at wall works cutting fan on/off. The light on fan does not work either by remote or switch. I am using one switch to cut fan and light on/off. I believe wiring at fan is correct. In the switch box, I have all the whites wirenutted together and pigtailed to switch, a blue and black wirenutted together and pigtailed to switch, and two black wires wirenutted together. Hunter ceiling fan about 20 years old if that helps. It was moved from one room to another. What is causing light not to work?

12/14 update: Problem has been resolved with fan. Changed to two switches at wall. There was some issues with wiring at fan that caused light not to work. Also changed wiring at wall switch to make work with two switches.

  • 1
    Can you post photos of the insides of both boxes? – ThreePhaseEel Dec 13 '16 at 2:18
  • I can't at this time. It is only one switch box. – georgia-guy Dec 13 '16 at 2:27
  • Do you get voltage at the input and the light output of the receiver with the wall switch on and the receiver set to light the light? – ThreePhaseEel Dec 13 '16 at 2:29
  • There is voltage to both sets of black wires wirenutted together that was mentioned in original question. The fan and light is mounted at the moment so I can't test voltage there right now. – georgia-guy Dec 13 '16 at 2:36
  • Does this fan have one pull chain for the fan and another for the light? – Jim Stewart Dec 13 '16 at 2:48
1

What are you talking about here:

I believe wiring at fan is correct. In the switch box, I have all the whites wirenutted together and pigtailed to switch, a blue and black wirenutted together and pigtailed to switch, and two black wires wirenutted together.

Are you talking about the box in the wall which holds the switch? If so, why are the whites pigtailed to the switch? Is this switch just a regular one-way mechanical switch? Or is it some new special switch that requires a neutral (white) connection?

Or when you say "switch box" do you mean the rectangular receiver which is under the cover where the fan attaches to the ceiling? If this is the case it sounds like you may have the whites wired wrong.

The receiver in my Hunter fan has two white stranded wires. One of these (labeled "neutral in") is wire-nutted to the solid white in the house wiring. The other (labeled "common out") is wire nutted to the stranded white common neutral in the fan. So my fan has a neutral common to the fan and the light. If your fan has a separate neutral for the fan and the light, then I presume both of these would be wire nutted to the "common out" wire of the receiver (so 3 wires in that wire nut).

So all of the whites are not supposed to be wire nutted together and pig-tailed to the switch.

My receiver also has two black wires and one blue wire, all stranded wire. One black is labelled "live in" and is to be wire nutted to the solid black of the house wire. The other black is labeled "fan out" and is wire nutted to the stranded wire that powers the fan. The blue wire is labeled "light out" and is to be wire nutted to the stranded wire that leads to the light.

  • Our fan had suddenly quit working a few days ago and I took out the receiver, made the straight connections and found the fan and light both worked with the pull chains. Today I tested the receiver/transmitter with a simple test apparatus and found that they controlled both light and fan with a 40 W halogen bulb as the load. I replaced the transmitter into the fan and both fan and light work. Probably one of the wire nut connections was bad leaving the switch unpowered or not properly powered. It was a little bit of a pain to get the receiver in place (vents up) with wires in the way. – Jim Stewart Dec 13 '16 at 21:01
  • The easiest test apparatus is to take an old lamp (pref. w/ polarized plug) and cut the cord and strip all 4 ends. Mark the plug and lamp ends black on hot and/or white on neutral. The receiver will be connected across this break according to the instruction for connecting the fan/light except that only one of the outputs of the receiver can be connected at one time. Connect the light output of the receiver to the lamp and see if the light button switches the light on and off. Then disconnect the blue and connect the fan output to the test light. The fan buttons should now work on light. – Jim Stewart Dec 13 '16 at 23:58
  • With above test apparatus do not leave it plugged into wall receptacle with the ends uncovered. Also note that when in use, the unused output of the receiver (light or fan) may be energized (hot) so it should be covered with a small wire nut. Make all connections and then plug into the wall last and operate the transmitter to test the transmitter and receiver. – Jim Stewart Dec 14 '16 at 0:19
  • I haven't had a chance to try suggestions yet, but I did wire black wire from house to bottom of switch, fan black , light blue, and a pigtail to top of light switch. I got voltage at light and fan, but neither came on. – georgia-guy Dec 14 '16 at 3:14
  • When you write "switch" immediately above do you mean the remote controlled switch (aka the receiver)? Does your receiver have wires coming from it or does it have screw terminals? – Jim Stewart Dec 14 '16 at 10:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.