1

I've got a drain assembly like the 2nd image in This answer.

My problem is exactly like the one in that question except I'm trying to fix the non-working assembly instead of unclog the drain. it is stuck in the open position. I removed the face plate and the rod doesn't pull out like I see in the countless videos online. I tried using a pair of pliers to pull up on the rod but it won't budge.

Thoughts?

6
  • 1
    Pivot between trip lever, up top, and vertical rod may be seized with hard water deposits. Take off the overflow plate cover, and try yanking directly on the vertical rod. Might come loose, or you may need to treat with vinegar, then rinse and lubricate. Nov 24, 2016 at 2:52
  • Yeah, that's what I meant by pulling on the rod. I'll try vinegar to loosen and report back.
    – kinar
    Nov 24, 2016 at 2:57
  • @WayfaringStranger so far no luck with vinegar. I suspect you are right that is is a hard water deposits since our water is very hard when not softened and the water softener was non-working when I bought the place. It seems the stopper might be one of the hollow ones so yhe venegar just runs right down the drain.
    – kinar
    Nov 26, 2016 at 0:47
  • I've tried using CLR, but it hasn't helped. I tried using a screwdriver that I hit with a hammer. But the plunger is still stuck (won't move up OR down). What worked for you? Thanks.
    – Ryan
    Jan 2, 2023 at 22:48
  • 1
    @Ryan unfortunately, I'm not in the same house anymore but I don't recall ever solving the issue and instead just used a stopper to plug the tub
    – kinar
    Jan 10, 2023 at 22:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.