0

i have a trane xl 90 . tried turning on heat for the first time this fall. everything works good till its time for the blower motor to come on, then it shuts down and waits a few minutes and starts the cycle over again. Fan works with air condition, or in manual. Just wont come on after the ignitor has lite the pilot and it burns for a minute

  • 1
    Is the main burner lighting and then shutting off without the main fan coming on? If so, it may be that the sensor which detects the heat is not working and not turning on the blower. (This sensor is supposed to delay the starting of the main blower until the heat ex-changer is hot so that it doesn't blow cold air at the start of an on cycle.) After too long without the blower on the heat ex-changer overheats and its shutoff sensor signals for the gas to the main burner to shut off. – Jim Stewart Nov 20 '16 at 20:22
  • 1
    What error code is presented? – isherwood Nov 20 '16 at 20:29
  • How long does the burner run before it shuts down? Blowers are usually on a 30 to 45 second delay. If the burner is shutting down before that (10-15 seconds), the flame sensor is bad. – Tester101 Nov 20 '16 at 22:14
1

There's a flame sensor (as opposed to a heat sensor) that can become coated with combustion products. These can be cleaned, or it may need replacement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.