0

I have hot water in every other faucet of my house, but the MBR Shower. While for 15 years it has given me hot water,it now only gets lukewarm water (not very good for taking a bath). I've replaced the shower mixing valve, but still do not get hot water. While it fixed a drip in the shower head, it did not fix the temperature issue. I tried multiple settings on the high temperature control on the shower valve and even removed the high temperature control stop, but it has not resulted in hot water in the shower. Could the water pressure balance valve be the culprit? Any other ideas?

  • Hello, and welcome to Stack Exchange. A picture of, or the manufacturer/model of, the shower valve would help. (My guess is that it's the anti-scald valve.) – Daniel Griscom Oct 16 '16 at 0:37
  • 1
    Sounds like an anti scald valve is going bad. It has worked for 15 years so something in the valve has failed. – Ed Beal Oct 16 '16 at 1:12
  • The valve or shower head/spout could have debris collected behind the filter that is blocking flow or if there is a bias control built into the valve itself that might need to be adjusted. – Dopeybob435 Oct 17 '16 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.