Tweeted twitter.com/StackDIY/status/1104758943434313728
2 edited title
source | link

Flushmount Why does my LED Light Issuelight flicker when turning it on using a dimmer switch?

I replaced a flushmont light fixure with a new dimmable LED Flushmount. I also replaced the old switch (see images below) with a dimmer switch. When I turn the LED on there is a flicker while it is turning on. After that initial dimmer it seems to work fine and the dimming feature works well.

A video of the light turning on is in the following linkHere's (slightly too large of a file to upload directly): https://app.box.com/s/6ngj5ag03zx14sr436wc01y2zb9fk1x3a video of the light turning on.

The dimmer switch that I installed is a toggle dimmer (this one) with 2 brass screws, one copper screw, and a ground wire. There was no ground on the old switch, so I connected one black wire to one brass screw, the other black wire to the other brass screw, and the blue wire to the copper screw. Since I am using this as a single pole switch, my understanding is that it shouldn't matter much.

My questions: 1) Is this simply due to having a single LED light on a dimmer? 2) Should I be concerned about my connections in the flushmount fixture or switch? 3) The old switch had the two black wires under one screw. Should I do the same on one brass screw in the new switch?

Thank you for any help!

enter image description here enter image description here

Flushmount LED Light Issue

I replaced a flushmont light fixure with a new dimmable LED Flushmount. I also replaced the old switch (see images below) with a dimmer switch. When I turn the LED on there is a flicker while it is turning on. After that initial dimmer it seems to work fine and the dimming feature works well.

A video of the light turning on is in the following link (slightly too large of a file to upload directly): https://app.box.com/s/6ngj5ag03zx14sr436wc01y2zb9fk1x3

The dimmer switch that I installed is a toggle dimmer (this one) with 2 brass screws, one copper screw, and a ground wire. There was no ground on the old switch, so I connected one black wire to one brass screw, the other black wire to the other brass screw, and the blue wire to the copper screw. Since I am using this as a single pole switch, my understanding is that it shouldn't matter much.

My questions: 1) Is this simply due to having a single LED light on a dimmer? 2) Should I be concerned about my connections in the flushmount fixture or switch? 3) The old switch had the two black wires under one screw. Should I do the same on one brass screw in the new switch?

Thank you for any help!

enter image description here enter image description here

Why does my LED light flicker when turning it on using a dimmer switch?

I replaced a flushmont light fixure with a new dimmable LED Flushmount. I also replaced the old switch (see images below) with a dimmer switch. When I turn the LED on there is a flicker while it is turning on. After that initial dimmer it seems to work fine and the dimming feature works well.

Here's a video of the light turning on.

The dimmer switch that I installed is a toggle dimmer (this one) with 2 brass screws, one copper screw, and a ground wire. There was no ground on the old switch, so I connected one black wire to one brass screw, the other black wire to the other brass screw, and the blue wire to the copper screw. Since I am using this as a single pole switch, my understanding is that it shouldn't matter much.

My questions: 1) Is this simply due to having a single LED light on a dimmer? 2) Should I be concerned about my connections in the flushmount fixture or switch? 3) The old switch had the two black wires under one screw. Should I do the same on one brass screw in the new switch?

Thank you for any help!

enter image description here enter image description here

1
source | link

Flushmount LED Light Issue

I replaced a flushmont light fixure with a new dimmable LED Flushmount. I also replaced the old switch (see images below) with a dimmer switch. When I turn the LED on there is a flicker while it is turning on. After that initial dimmer it seems to work fine and the dimming feature works well.

A video of the light turning on is in the following link (slightly too large of a file to upload directly): https://app.box.com/s/6ngj5ag03zx14sr436wc01y2zb9fk1x3

The dimmer switch that I installed is a toggle dimmer (this one) with 2 brass screws, one copper screw, and a ground wire. There was no ground on the old switch, so I connected one black wire to one brass screw, the other black wire to the other brass screw, and the blue wire to the copper screw. Since I am using this as a single pole switch, my understanding is that it shouldn't matter much.

My questions: 1) Is this simply due to having a single LED light on a dimmer? 2) Should I be concerned about my connections in the flushmount fixture or switch? 3) The old switch had the two black wires under one screw. Should I do the same on one brass screw in the new switch?

Thank you for any help!

enter image description here enter image description here