Sign up ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

I've got an off-line Hayward chlorine tablet feeder on my pool (it has a 1/4" hose that taps off some water from the pressure side of the pump before the filter, and it outputs via 1/4" line to the return lines after the filter).

This thing has a screw-top to seal the chamber where the chlorine tablets go, and it has a latch mechanism - if you screw it on far enough, it latches to prevent the top vibrating off.

This thing is only 3 or 4 years old.

At this point I can't close it completely (it's simply too tight to screw on any further). When last I did have it completely closed, it took me over an hour to get it apart. It doesn't leak, and various tests (unscrewing various fittings) shows that it is working.

Anyone know what's gone wrong here? It's almost like the plastic has changed shape in some way. Any idea how to fix it? It's not an expensive part ($60 or so), but it's only a few years old, and it seems to me it shouldn't need replacing already.

share|improve this question
As an interesting side note, I was at a friends recently, and they've had no problems with theirs. I'm wondering if the fact that it's inside a shed (all my pool equipment is inside) has something to do with the issue. – Michael Kohne Jul 24 at 1:38

4 Answers 4

up vote 2 down vote accepted

The O-ring for the cap on my Rainbow chlorinator didn't last more than a couple of years. Perhaps you need a new one. My O-ring actually swelled and got bigger. I keep mine lubricated with silicone grease.

share|improve this answer
Yea, the O-ring was toast. Before I could get a new one in place it actually got so bad that the feeder was leaking and I had to buypass it. A new O-ring fixed that right up. Unfortunately, I still have trouble screwing it on to the latch point. I'm becoming convinced that screw-tops (for all their mechanical design advantages) are for the birds on pool equipment - they're just too much trouble to get open and closed properly. – Michael Kohne Jul 6 '11 at 23:35

If it is filled with water, you are not only fighting against the original friction and any other junk that might've made the seal stronger over time, but you're attempting to unscrew something, which makes it withdraw, forming a vacuum.

Try to get some air into it by opening up the air pressure relief valve atop your filter, or by draining your filter. Then whack it with some moderate force with a screwdriver. Also, if it has a handle on top, you could use a long bar/screwdriver/whatever to create more leverage.

If you manage to get it off, lube it up with regular ol' pool lube or T Plus 2 pipe dope (liquid teflon).

Also, tablets pretty much suck. They mess up your chemistry pretty bad, putting too much cyanuric acid into the pool, which NEVER goes away (unless you drain the pool) and forces you to put more and more chlorine tablets into the pool. Unless you drain your pool yearly, your pool's chemistry is in a slow but irreversible death spiral. If your pool is compatible with salt, salt water chlorine generators are far superior and are highly recommended.

share|improve this answer

Just like any other threaded thing, try the following:

  • clean the threads
  • use appropriate lubricants or sealers
  • replace any seals (sounds like you already did O-rings)
  • check the threads for damage
  • unless the manual specifies that you have to use some force to tighten the device, you shouldn't force it
share|improve this answer
Yep, did all that (the o-ring is the only seal). The thing did NOT require force when new. My guess is that either due to temperature cycling over the winters, or due to chemical attack from the chlorine, the thing has expanded, causing the problem. – Michael Kohne Jul 28 '11 at 16:22
Do you think the cap has expanded or that the container has shrunk? I assume this is a PVC-like plastic which has a bit of natural slickness to it. Is there a lubricant or restorative you can use? Perhaps teflon tape? – Freiheit Jul 28 '11 at 17:10

I have the same problem with a brand new Hayward feeder. I use a rubber strap wrench to get it off, but even then it's killer. Since the top has the indents, I'm thinking there must be a wrench that is made for it. If I can't find one, I think I'll be making one (likely out of plywood).

share|improve this answer
I don't know if there's a wrench for that one. I know there is (because I have one) a wrench for removing the screw top lids on their pumps, but I haven't seen one for the feeder. – Michael Kohne Jul 28 '11 at 11:48
There is a wrench - I had one and it works like a dream - my problem is that it has been stolen - I need to know where to get it replaced - a wrench to open a Hayward automatic Chlorinator – user39174 Jul 6 at 17:58

protected by Community Jul 24 at 13:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.