Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

I have a Kenmore HE3 electric clothe dryer. The problem is that it has no heat even its drum is turning. (I set the temperature at high).

The owner manual says it may have a fuse blown.

Is the fuse inside the front panel with all the electronic components or at the back? I don't even know how to take out the front panel.

share|improve this question

3 Answers 3

Check your circuit breaker or fuses. Your dryer is connected to a 240v pair of breakers (or two fuses); the control and motor probably run on one 120v leg while both are required to provide 240 to the heating element. There's a small chance that one fuse or one pole of the breaker has tripped (it should cause the other to trip as well, but...). If it isn't that, it is most likely the heating element.

share|improve this answer
    
This is exactly what happened to me, and it took me a long time to figure that one out. It's an easy check to get out of the way first, at any rate. –  Michael Jul 25 '11 at 19:44

Try inspecting the heating element, it could have a break in it somewhere.

share|improve this answer

It's not shown in the user manual? Some W/D units open by lifting the top up (hinged at the back) by using a putty knife to release a clip on the front.

share|improve this answer
    
I figured out. One access panel is at the bottom on the front, and another is the top with two screws at the back. –  TCL May 3 '11 at 1:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.