Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

Hope this is on topic for this stackexchange.

I recently bought a lamp from the US and had it shipped to Australia. Stupidly I powered it straight off the mains through an adapter. The device is rated at 120V 60Hz and Australian mains are 240V 60Hz. The lamp turned on for a split second and wouldn't power on at all after that. The device has a fuse in the back of it that appears to still be whole, the manual says this should be replaced if the lamp no longer dims correctly.

Have I written off the device or is it possible that it has remained intact? (I know it is impossible to say definitively but some information would be of great help)

share|improve this question
    
I did this with a Dremel once. That was visually stunning. –  Andrew Heath Mar 30 '11 at 6:10
    
+1 for introducing me to a new term that I will incorporate into my vocabulary directly, "boned" –  kmm Apr 2 '11 at 15:27
add comment

1 Answer 1

up vote 5 down vote accepted

Does the device have a transformer or similar internal electrics?

If so there's a very good chance you've burnt it out. The fuse only protects against excess current - not incorrect voltage.

share|improve this answer
    
I'm not sure about the electrical internals, but it is a reasonably expensive and sophisticated lamp so it's quite possible. Since it is expensive is it worth taking it to a repairer to have a look? –  radman Mar 29 '11 at 22:26
    
@radman - it couldn't hurt. A decent place should look and quote for repair without charging you so you won't have lost anything. –  ChrisF Mar 29 '11 at 22:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.