Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

I have a board, which has three switches. When I connect my PC's power card to that board, I see a spark in the switch. However, if I connect a TV or a radio, I don't see any sparking.

Do I have to replace that switch? The entire board? Do I have to check the power supply of my home? I suspect that this problem may be occurring due to voltage variation.

share|improve this question
3  
It's not clear from your question what you mean by "board"? I'm guessing maybe a "power bar"? A picture might help, as well as what country you're in (which will tell us what voltage, type of plugs, etc). –  gregmac Mar 10 '11 at 21:23
1  
@gregmac: looks like the OP is in India, which has 230V @ 50Hz –  Doresoom Mar 10 '11 at 22:14
1  
Just found this resource for voltage, frequency and plug type: kropla.com/electric2.htm –  Doresoom Mar 10 '11 at 22:17
    
if this turns out to be a computer problem this question would be better suited for Superuser –  allindal Mar 11 '11 at 20:23
add comment

1 Answer 1

It sounds like the PC's PSU is either on, or draws considerable power even when it's supposed to be "off". I'd be looking at replacing the PSU.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.