Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

At one of rental properties we have a GE GSH25JFXN WW Refrigerator. Our tenant changed out the water filter because of the recommended time to change it. He said that before he changed the filter there was good water flow at the water dispenser. After changing the filter, water flow at the dispenser was slow. Here's his e-mail before I went out there yesterday

"Thanks for the email. I changed out the filter because it had been on for longer than 6 months. When I took the old filter off, that's when I noticed there might be a potential leak (where the filter is attached). I installed the new filter and the water would barely come out. I've changed out the filter before and never had this issue. I gave the reservoir time to fill and I also held down the water dispensing mechanism for 5 minutes (at the request of GE customer service to make sure any air was pushed out of the tubing). Was still slow coming out. GE recommended trying another filter in case the one i got was defective. I bought the official GE MWF water filter each time and am still having the same problem. My rough estimation is that it's taking 7 seconds to fill about 1 ounce."

Here's picture of the point of connection for the water dispenser. Also when you take out water filter, it kinda leaks at connection and it stop when I press on a little white button on the right.

enter image description here I went there yesterday to try a some things:

  1. I check to see if there weren't any kinks in the piping. I found none.
  2. I tried this solution. http://boogster.blogspot.com/2011/10/ge-profile-refrigerator-slow-water.html I didn't know what part the person was sharpening.
  3. I tried cleaning the water discharge at the filter with a pipe cleaner and didn't feel like there was any blockage there.

So I noticed that he turned off the icemaker. I asked him to turn on the icemaker to see if any ice were to be mad. This was around 5:30pm yesterday. I followed up with them today (12 noon) and he said the following

Just looked actually. Ice was made but not very much at all. The ice was also thin and even hollow in some spots so it's not getting very much water to make the ice.

I wanted to see if it's main water supply to refrigerator or something that is just affecting just the water dispenser. I have attached pictures of the water filters for reference. There is a slight difference in the both of them. The old one is on the right.

enter image description here

share|improve this question
    
I do not have a solution but I can tell you that there is no pump, only a valve that accepts water coming from the filter and allows it to flow into the ice maker or into the water outlet. I had this same problem and a repairman told me it was the valve. I replace the valve and it was still slow so I replace the filter and it was perfect...for a couple of months. Now we are back down to a trickle. –  Jim Clark Sep 13 at 11:30
    
What happens when you put the old filter back on? -Related: diy.stackexchange.com/questions/49096/… –  Mazura Oct 6 at 1:26

6 Answers 6

I had the same issue and it turned out to be air in the system. When you install a new filter, it's full of air. I took out the filter, dumped out the water out of the filter, refilled the filter in the sink, and reinstalled the filter. It took a few tries to get all of the air out of the system.

share|improve this answer

Yes, air will have that effect.

Other things to consider... If there is a valve that feeds the fridge, make sure it is all the way open (even if there is no need to shut it off to change the filtrr... The tenant may have done so and then not turned it all the way back on).

Also, for my fridge at least, not all filters are the same. The whiz bang filter model that includes carbon flows much more slowly than the cheap filter.

Last, I've never seen a fridge with its own water pump. They just use line pressure, hence my advice to make sure all feed valves are all the way open.

share|improve this answer

I've just ran into the exact same issue with our GE water dispenser. I'm suspecting the water pump since the water pressure at the filter hookup is good. It will fill a bit, then pump a bit out and then slow down to a crawl. Every other time I've replaced the filter, the water shot out like crazy.

share|improve this answer
1  
Do you mean specifically the water pump for your well, or a water pump inside the refrigerator? –  TDHofstetter Aug 24 at 0:10

When I had the same issue I just bypassed the filter by connecting the water source directly to the water inlet.

This showed me that there was an issue somewhere between the water filter and the water inlet.

share|improve this answer

The problem is the filter. After years of experiencing slow water (directly after changing filter) I took the filter out and inserted the bypass. Now a glass that took 3 mins to fill takes 3 seconds. I read somewhere that the problem can be solved by putting a dime sized washer over the head will also fix it. Apparently the filter is obstructing the water flow.

share|improve this answer

Well I took a look at the new filter and it had an o-ring in side the filter, and I took this out, re-installed the filter and water flows like it did when new. So it appears the filter have evolved. I figured since the valve already had two O-rings I would be safe. Water flow good and no leaks

share|improve this answer
    
Are you the same person as mguzman72? –  TomG Oct 24 at 2:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.