Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

Our fireplace is about 7 years old and for the past couple of years, only the last opening in the burner has worked. I see the pipe's threading shortly where it comes out of the wall in the firepit, but when I try to turn the pipe with a wrench, the whole pipe, including the pipe the burner is connected to, turns. Any advice on replacing this pipe? And where I could even purchase a burner like this? Thought I would ask here before calling a chimney sweep.

Burner with one working opening
Click for larger view

share|improve this question
2  
Have you tried cleaning the orifices out with a wire brush? It's probably clogged. If it's a gas fireplace, why is there so much ash in there? –  Steven Jan 5 at 17:39
1  
^ Im thinking the same thing. This appears to be a very unsafe condition. Get the unit looked at and cleaned thou roughly by a gas technician. If this is indeed a gas log set, i would recommend replacing the whole unit as they are relatively cheap compared to an actual sealed fireplace. –  Mnc123 Jan 5 at 19:14
2  
Is this a gas fireplace, or a gas start for a wood burning fireplace? A better picture of the joint where the burner connects to the piping would be useful. Typically you'll need two wrenches. One to hold the fixed piping, and one to turn the burner. If the whole thing is turning, you're likely unscrewing it from a joint further up the piping (and potentially creating a gas leak). –  Tester101 Jan 6 at 11:38
    
I just looked at the high res image and this really looks like a piece of pipe with holes drilled in it. If this is the case you should stop using it! –  Steven Jan 7 at 1:51
    
Sorry for the late response. @Steven, I will give that a shot. I've tried scraping but not with a wire brush. This is a wood burning fireplace with a gas starter. This house was built in 2005 and I'm the only owner. I've tried the double wrench approach and it won't budge. Guess there's nothing I can do on my one. Thanks everyone. –  Nik Majdan Feb 2 at 1:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.