Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

I have a Whirlpool 40 gal gas water heater that I got around 2 years ago.

Doing dishes tonight, I noticed the warm water was getting colder. When I went to check the water heater, the signal light which indicates proper function was off. It had been continuously on since I got it.

I first tried reigniting it following the instructions on the heater: turned the little knob to PILOT and kept clicking the igniter button once every second but the light wouldn't come on.

Then I thought that some weird little object could be stuck in between the gas pipe shutoff valve and the heater so I disconnected the yellow flex connector at the heater and confirmed that that was not the problem -- the gas flow was normal.

When I reconnected the pipe, I went ahead and tried reigniting the pilot, the same as before. This time it worked after a few tries but the heater would actually not start heating water. In other words, even though the water in it is cold (I tried releasing a few drops from the drain valve at the bottom), the flames don't light up and the heater remains cold. So I have no hot water now.

The little signal light is not powered by external electrical supply but instead there is something inside the heater that generates the low voltage out of I guess burning gas. So evidently, the pilot flame IS burning inside the heater but the burner won't come on.

What could be the reason of this malfunction?

share|improve this question
    
Including the model number of the appliance is often helpful. –  Tester101 Dec 16 '13 at 12:17
    
No electrical inlet? There must be a battery box in there! –  Roberto Dec 16 '13 at 13:26
    
I'm trying to find a picture, but if you feel confident doing it, please look at the bottom of the heater and see if there isn't any plastic box with a twist-to-open catch or something alike. –  Roberto Dec 16 '13 at 13:30
2  
STOP! People can and do blow themselves up messing around with gas appliances. Reading your question, especially the part about the removing the flex line to check for gas flow and then trying to relight the pilot, leads me to believe you don't have experience with this. There could be a number of things wrong including poor pressure from the utility line or malfunctioning flame sensor. Call your utility company. Mine will send over someone to diagnose the problem at no charge. I have a warranty with them for most repairs but yours should still be under manufacturer warranty. –  OrganicLawnDIY Dec 16 '13 at 14:47
1  
@amphibient, you might want to revisit how your ego is coming out in this question. OrganicLawnDIY is correct to note that messing with the gas supply as a first step is a red flag. Immediately taking offense, and then verbal hostility directed towards those trying to help you, is not the best course of action. –  Reid Dec 18 '13 at 3:27
show 9 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.