Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

So I have a relatively new dishwasher that just completely stopped working the other day. It's still under warranty but before going though all the hassle I want to check if there is nothing simple it could be.

I have checked all the basics such as fuses in the plug and if the socket actually works with other appliances. I have not yet opened it up but have no problem with doing so if there are any good ideas as to what could be the problem.

I remember the night before it stopped showing any signs of life it made some strange beeps just after finishing a cycle.

So far the net has not provided any clues.

its a LG, not sure on the exact model and seems like each store sells the same thing with different model numbers anyhow.

It has the text 'Inverter DirectDrive' and 'TrueSteam' on the front

share|improve this question

3 Answers 3

up vote 2 down vote accepted

So got the company out to fix it under guarantee and turns out it is just a very poorly designed system for buttons. It seems to be a AC Hum touch type button. The dish washer has small sponge (5mm x 5mm) wrapped with some conductive material which is meant to be attached to metal rods which forms the button inside the machine.

This gives the 'soft touch' as there is no moving parts like a normal button.

The problem was that these little sponges had fallen off the metal post which stopped it from working the way it was intended. Simple fix to re-attach the sponge back into place.

Well the fix from the guy that was sent out lasted all of 3 days before it broke again so this time I opened it up and fixed it myself (hopefully permanently).

Dead simple job, about 15 minutes taking the front panel off and glued them back into place with some contact adhesive.

Hope this will help someone else that has problems with a 'soft touch' button that will not work any more. Should be a similar type system for other soft touch buttons found on appliances.

share|improve this answer
    
Nice. Thanks for sharing. –  wallyk Dec 15 '13 at 17:15

Check the appliance's power cable shows no signs of damage.

The appliance's manual will state if the appliance has a separate and accessible fuse (unlikely I think).

If the front display panel shows no indications of power - no lights/LEDs illuminated, completely blank LCD etc, no sounds from the pump when controls set to drain etc. In that case you should really return it to the vendor under warranty and get a refund or replacement (your choice)

Opening it up will void your warranty and leave you liable for the cost of any parts that need replacing.

share|improve this answer

I have just finished fixing our LD1454TFES2 LG Truesteam DirectDrive. It developed an intermittent power fault where the power button would only work.. sometimes. We scratched our heads , stood on one leg , crossed fingers as that seemed to help... well it did, sometimes, then it finally wouldn't power on at all. I checked all the blogs and heaps of people have had the same problem. but dogmatic69's post above is the best answer on the internet! The little sticky pads that connect the internal buttons to the plastic shell (Panel Assembly) had simply slipped off. LG know this is a problem - since later versions of the part AGL73457207, the Panel Assembly, have an improved design to stop the pads slipping off! ( raised circular housings on the interior panel at each button point.) Great machine - but we almost lost it - worth fixing.

share|improve this answer
    
I have called them out so often that they actually just came one day and took it away. Got a new replacement. Not had any issues. The one I had must have been a dud, new one has no issues (6 months in) –  dogmatic69 Mar 23 at 10:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.