Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

All except one radiator are working fine. The one that stays cold is in the room with the thermostat, so the system keeps running more than it should.

I tried bleeding it and just water came out. I let it bleed for some time and the pipe which comes down from the ceiling did slowly warm up, but the radiator never got warm the next day the pipe was cold again. The pump was replaced a year or 2 ago and seems to be working fine.

It worked last year. Could there be some sort of blockage? If so, what can I do about it? We are in a hard water area.

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

You may have a air lock in your pipes.

Turn of all other radiator, and see if your pump is powerful enough to get water into the cold radiator. If this works, then you need to bleed it again.

share|improve this answer
    
That got it to warm up. I'm hoping that has cleared it. Thanks –  steevc Dec 3 '10 at 15:54
    
@Steevc in our current place we had to do it 2 or 3 times but it is now all working OK for us. –  Walker Dec 5 '10 at 18:46
    
It was cool the next day. I'm repeating the process. Didn't seem to be any air in there. –  steevc Dec 5 '10 at 19:00
    
@Steevc, if the pipe is longer to that radiator then the test you may need to "balance" the system by part closing down the "lock shield" values the radiators that are get hot quickest. –  Walker Dec 6 '10 at 14:58
add comment

Is you expansion tank full? This same thing happened to me a few years back, and I had to have the expansion tank drained because it was "saturated" and wouldn't allow any more water into the tank.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.