Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

Yet another follow-up to How does one determine whether a waterlogged High HP pump is electrically OK to use?

The pump is out now. The screws on the housing being jammed/rusted tight, I've applied some rust-remover. Hopefully that shall do the trick. Whilst I wait for the rust-remover to do it's job, I'm wondering about the OEM condenser attached. It doesn't look like it was submerged, and seems OK electrically on the multimeter ...

EDIT: In this simulacrum, the condenser/capacitor is the cylindrical object mounted atop the centre of the device body. To test it with the multimeter I set it in applied the probes to the terminals. This had the result of showing the resistance increase gradually as the capacitor charged up.

My thoughts

  1. If this condenser is indeed bad/soon-to-be bad, what damage could it do to the pump?
  2. Out of curiosity - what happens if the replacement condenser is not of identical rating but rather is rated higher/lower?
share|improve this question
    
I don't know what part you're talking about. Perhaps you mean capacitor? But that is either sealed inside the pump (if a two-wire pump) or in the control box at ground level -- and either way doesn't make sense along with the statement "doesn't look like it was submerged". Can you take a picture or point this part out on a diagram? What did you do to test that it was "OK electrically"? –  gregmac Aug 7 '13 at 14:53
    
@gregmac: Updated (+: –  Everyone Aug 7 '13 at 17:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.