Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

I have the blue Hoover pet cyclonic vacuum. It worked fine for a few months, but now when I push the foot lever to lower the handle when I vacuum, the brushes stop spinning on any carpet level setting. Once the vacuum is locked into an upright position, they spin perfectly.

Why is this happening and how can I fix this?

share|improve this question
1  
Start by consulting the owners manual for how to check/tighten belts. –  Tester101 May 2 '13 at 15:58
add comment

1 Answer

Make sure this is a bug, and not a feature

When the vacuum is in the upright position, the agitator should not rotate. When the handle is lowered the agitator should be engaged, however, some models offer a manual agitator shut off feature. Make sure if your model has this feature, it is not turned on.

Agitator Brushroll Shut Off

Check the hose

Next ensure that when you lower the handle, the attachment hose is not becoming dislodged. On some vacuums if the hose is removed, the lower portion of the vacuum disengages.

Check the belts

If one of the belts becomes worn or stretched, the agitator may spin fine until it comes under load. Once the agitator meets resistance, the belt slips, and the agitator stops spinning. Consult the user manual on how to check and replace belts in your particular model.

Belt
V Belt

Image source: Pet Cyclonic Bagless Upright Owners Manual.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.