Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

I have a Whirlpool gas oven Super Capacity 465.

The four cook-top burners work ok.

When I turn on the oven on broil, I hear gas hissing and igniters ticking. Within a second it ignites the top burner inside the oven. I could see flames from the jets.

On the other hand if I use the bake setting (to use the lower burner). I hear gas hissing, igniter ticking but it doesn't light up. It stops for a minute or so and tries again. It does light up rarely sporadically but not dependable. I opened the bottom panel to expose the burner and sprayed some oven cleaner over the jets. No luck. If I manually ignite the lower burner, it ignites. To try this I lighted up a small piece of paper, close the oven door and turn on the oven on bake setting. When the lower burner is burning, I can see all jets have a flame. I did this only to diagnose and later closed the bottom panel.

I have used the self cleaning feature of the oven a few times already without any luck.

My issue is similar to this but in my case the igniter is firing.

Some time back I discovered a gas leak from behind the oven but it was fixed by the gas company. They unscrewed the gas inlet hose and applied some kind of grease and tightened it again. I'm not sure if this could be related.

share|improve this question
    
I believe that the bottom igniter is dead. I opened up the base plate and while I can see the sparks from the top igniter, there were no sparks at all from the bottom igniter. Amazingly it worked somehow yesterday. –  Chetan Bhargava Jan 12 '13 at 0:51
add comment

1 Answer

up vote 1 down vote accepted

Since the oven has two burners, it would of course have two igniters - but either igniter could be busted and the other would still make noise. Can you look at the igniters? Are you sure both are firing? Because it would be easy for something to have fouled the lower igniter.

You really want to see that the igniter sparks at least as bright as the upper one before you say that it works.

share|improve this answer
    
Yes, I see the bottom igniter firing. I see blue sparks from the igniter. As I mentioned, it works sporadically. –  Chetan Bhargava Dec 23 '12 at 20:29
    
@ChetanBhargava - ahh. I missed that it was working sometimes. When you manually light it, do all the gas ports on the burner work? I'm guessing yes. In that case, it's gotta be the igniter itself - I think they are basically a spark gap, and if something gets in that gap, or if one side gets tapped (making the gap close) the amount of energy in the spark will end up changing, and may not light the burner. You could try looking at the igniter with a magnifier and see if it looks fouled or damaged, but it's probably got to be replaced. –  Michael Kohne Dec 23 '12 at 22:15
    
To look at the igniter, I would have to remove it. It is located in the deep end of the oven. Is it easy to remove the igniter? Thanks. –  Chetan Bhargava Dec 24 '12 at 20:12
    
It seems that the bottom igniter doesn't fire at cold start. My oven worked yesterday but did not today. So I opened the base plate and manually ignited it and replaced the plates. The baking started and after some time, the bottom burner stopped to maintain the temperature. A few minutes later when the temperature was down, it ignited by itself. I I heard the clicks and it ignited. –  Chetan Bhargava Jan 12 '13 at 1:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.