Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

After flushing, my toilet doesn't sense that it needs to refill. See the below image. If I so much as gently touch the gray piece, the toilet starts to refill. Any easy fixes?

enter image description here

share|improve this question

3 Answers 3

up vote 2 down vote accepted

I've dealt with the same problem with the same float. In my case it was grit and gunk that got between the float and the cylinder that was keeping it from sliding easily. All I did was turn the water off and clean it up with kitchen/bathroom cleaner and a rag. You clean the top area, then slide the float up, then clean underneath. Chances are you'll feel the binding when you slide it up and down, it will feel like it's catching on individual particles. Once it is clean enough you won't feel that binding anymore.

share|improve this answer
1  
I did this as the first step. While it improved the situation, it didn't solve it 100%. I also tried BMitch's advice above but that didn't work either. So I just bought a new one. But at a minimum your solution is worth a shot before buying a new valve since its so simple. –  maxedison Dec 10 '12 at 17:28
    
@maxedison, thanks for that update, it's good to hear what really happened. Sorry it didn't work for you, sometimes things just can't be fixed. –  GdD Dec 10 '12 at 19:51
    
Say, what if a bit of water were to find its way inside the float? Then it would lose some buyoancy and not rise as high as before or push the valve with as much force. Any heavier-than-water gunk and calcification sticking to the float itself will weigh it down, too. –  Kaz Apr 15 at 18:56
    
Some adjustment may have to be made. It could be that the float is floating freely and correctly relative to the water level, but the level is rising high enough to leak into the overflow pipe without the valve being closed. Maybe something can be adjusted to close the valve. Else the valve is simply leaky. Maybe there is a simple way to extend the height of the overflow pipe. If you add a quarter inch to the height of the pipe (say with a ring of some sort of waterproof tape), it will raise the water level, and generate additional pressure on the float. –  Kaz Apr 15 at 19:00

I just had this problem. I did what BMitch described in his answer, and found the video linked by Lawrence Kesteloot to be very helpful just to understand what we're talking about. I found that in my case, after removing the cap off of the valve, the float was sliding up and down on the shaft very easily, so that didn't seem to be the problem. However, on the underside of the cap was a rubber seal that was causing lots of resistance. It was easy to pull off this seal and confirm that the arm went up and down without resistance when the seal wasn't there.

Here is what the cap and arm look like when removed.

picture of the cap

On the underside of the cap, I saw the black rubber seal with a pin that slides through it as the arm goes up and down.

enter image description here

The black rubber seal was easy to remove, and I found that the arm moved without resistance once this seal was off.

enter image description here

I tried cleaning the pin and seal, but I still found resistance when moving the arm. I decided to apply some lubricant. I didn't try searching very hard, but this quickly found link suggests it would be a bad idea to use a petroleum-based lubricant. I decided to use some medical lubricant (generic version of KY jelly) I had on hand. I don't know if this is a good long-term solution, and I suppose silicone lubricant from the hardware store would be a better idea. So far it seems to have worked!

share|improve this answer

Try to clean the valve by following these steps:

  • Shutoff the water to the toilet.
  • Flush the toilet to empty the tank (doesn't have to be completely empty, but you want some working space).
  • Open the valve by lifting the float to the top position, pressing down on the black plastic cap that covers the valve, and giving it a 1/8 to 1/4 turn. You should then be able to lift the cap directly off.
  • Clean sediment or other buildup off any small components of the valve, and if anything is easily detached, remove it temporarily for the next step. Be sure to check inside of the cap where the lever is attached.
  • While the cap is off, place a cup over the top of the valve and open the water supply for a few short bursts. The cup prevents a small geyser from appearing in your bathroom and the water will drain into the toilet tank (this is why you flushed it earlier). This process will clear any sediment out of the valve and supply line, including any sediment that may break free from the toilet shutoff valve.
  • With the water shutoff again, reassemble the valve, and attach it in the reverse process (lifting the lever on the float allows you to turn the cap with a little downward pressure on the cap).
  • Cross your fingers and turn the water supply back on.
share|improve this answer
    
That was it! I thought the floater was getting stuck on the shaft, but the problem was actually inside the valve itself. This is a good video explaining how to remove the cap: youtube.com/watch?v=J3RTqOlgP0s –  Lawrence Kesteloot Jul 17 at 23:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.