Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

The boiler lit and ran the other day, but now the pilot light was out. I could hear a hum at the control. I lit the pilot light, but when I no longer pressed on the valve, the pilot light went out right away. Is it a dirty sensor? What can I do to find out what is wrong?

share|improve this question
    
Have you looked at this question, this question, this question, or this question? –  Tester101 Oct 13 '12 at 20:42
add comment

1 Answer

Most pilot light devices have a sensor that detects that the pilot light is lit, and will shut off the pilot gas if it doesn't detect the lit flame.

This sensor must heat up in order to detect the flame, so after you light your pilot light, keep the pilot valve depressed for 30 seconds in order to ensure the sensor heats up. After 30 seconds, release the valve. If the light still goes off, repeat 1 or 2 more times.

Once the light stays lit, turn the valve to the ON or OPEN position and the pilot light will stay lit.

If the light refuses to stay lit even after several minutes of hot flame hitting it, then yes, you may have a defective sensor or other part.

share|improve this answer
1  
Thermocouple or thermopile is the "sensor" you are referring to. Though it's not so much a sensor as a device that generates a small amount of current when heated. Usually this powers a solenoid that keeps the valve open and gas running. In the case when you have to hold it, this is because the thermocouple does not provide enough power for the solenoid to open the valve on its own, but once its already open, its enough power to hold it open –  Steven Oct 13 '12 at 23:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.