Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

I have some power-line ethernet adaptors that worked great in my previous house. At my new house, they can't get more than a few KB per second because there's too much noise in the line according to the device statistics. How can I troubleshoot what's causing the noise, and what tools would I need?

share|improve this question
add comment

1 Answer 1

up vote 9 down vote accepted

You could start by turning off circuits at the service panel one at a time until the noise level drops. Once you have it isolated to a particular circuit, turn off or unplug devices until you find what's causing it. The usual suspects for electrical noise in houses would be motors -- fridges, washers, etc. -- and fluorescent lights generally the 4' or 8' long tubes with magnetic ballasts, less so with CFLs (see Brian's comment below), so you should start with those circuits first.

If you can't isolate the problem that way, and if you can power your networking equipment from batteries (laptops, UPS, etc.) you could turn off the main breaker to the house and see if the problem is inherent to the wiring or environment.

share|improve this answer
    
Excellent answer! –  Mike Powell Sep 2 '10 at 14:03
3  
While CFLs are not as bad as the old long tube fluorescents, they (especially the cheaper brands) do generate a good deal of EM hash compared to other common electrical appliances. Replacing fluorescents/CFLs with alternate lighting has been known to cure a wide variety of interference issues. –  Brian Knoblauch Sep 2 '10 at 19:09
    
@Brian: thanks for that information. Updated my answer. –  Niall C. Sep 2 '10 at 20:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.