Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

This question may be a duplicate of Toilet Supply Line and Valve Leaking, but I have some different symptoms/troubleshooting steps, and the answer supplied for that question doesn't quite fit (though it may be a lack of knowledge on my part).

So one day (maybe two weeks ago), the toilet stopped filling properly. I knew enough about the basic mechanics of a toilet to take the tank lid off and check that the flush valve chain was connected and the valve itself was closing. Both were fine.

While I was in there, I noticed that the overflow hose wasn't running (didn't know what that meant, but had seen the inside of a working toilet tank to know this was suspicious). Also, the fill valve at the top was trickling water (down the arm bit). So I knew enough to know that, for whatever reason, the toilet wasn't refilling properly. To confirm, I filled it manually with water from the sink using a pitcher. Sure enough, flushed fine.

We made plans to call the landlord (this is a rental, by the way, which is why I'm hesitant to go much further than I have. Don't want to officially have it be "my fault" and get stuck with the bill). But we've put it off and mostly just rely on the trickle to take its toll until we can flush in an hour.

Tonight I decided enough is enough. We probably won't get around to calling the landlord because of other issues, and I'm tired of apologizing for the not-so-little surprises my wife keeps discovering.

So I read up on how toilets work, both at howstuffworks and at the Home Depot DIY site.

It seemed clear that I need to replace the fill valve, which costs 6 dollars and would make me feel like a champ and avoid a call to the super. But there was also a mention of it just being the washer and how it's easy enough to just pop off the valve and replace just that part (which is 2 dollars less and an easier job).

Well, before doing all that, I thought I'd check the washer to see if it was worn out. I turned off the water first, then loosened the valve. The washer looked fine, but there was some dirt in outer perimeter of the bit next in line (not sure what it's called). I ran a qtip around and knocked some out. I put it all back together and was about to turn the water back on when I thought to tighten the nut under the tank connecting the supply line.

I flushed and voila, overflow hose runs, tank filled in under a minute. Everything looked great. Then I flushed again (once it was done filling), and it was back to a trickle. I turned off the water, tightened the nut as far as I could (it's a simple hand-twist nut, no hardware but my hands involved so far in this story). Turned the water back on and got another good flush. Waited a few minutes after refill was done, flush tested, got the trickle.

So this time I turned the water off and back on, doing nothing else (which, by the way, I had tried 2 weeks ago with no luck, just to see if it would do anything). Turned it off and back on, nothing. Turned it off and back on a second time, refill kicks in like normal.

So now I'm at a loss. I have a much easier workaround then refilling manually (turning the water off and then back on 1-3 times will kick the refill back into action after several tests, including a "live" one hours later), but obviously there is still an issue.

With the workaround being related to cutting the supply line off and on a few times, it has me thinking there is an issue in the actual line (or in the wall), which I'm not going to even try to tangle with. I know I could spend the 6 dollars to confirm, but I wanted to see if anyone could confirm from all of the above details and steps if the issue was in the tank or pre-tank before I go to the trouble of replacing something that isn't broken just to avoid dealing with my landlord.

Also, there are no signs of leaking around the supply valve or the line or the connection to the tank.

Update:

I have tried running the water without the head fill valve attached to clear out any dirt. I can see sediment in there, but it can't get through the inset washer. I tried popping it out with a screwdriver, but it's about an inch deep into the fill pipe, so I don't want to crack it.

Also, I am noticing the following, in terms of the workaround:

  • I turn water off and back on, overflow hose kicks in, normal refill.

  • Re-flush. After tank is empty, the trickle begins, no hose.

  • If I turn water off and back on quickly, no fix.

  • If I turn water off, wait for trickle to totally stop, turn back on, hose kicks in.

So I'm definitely inclined to think it's in the tank/fill line/valve. But now I'm just curious if anyone knows a definitive cause/fix for the issue.

share|improve this question
    
Photos of the inlet valve, stop tap and inside of cistern?? –  UNECS May 9 '12 at 12:00
add comment

1 Answer 1

up vote 1 down vote accepted

It seems as if you have an obstruction that may be floating around in the pipe or valve. Sometimes it obstructs sometimes it flows clear. I would start with changing the water valve. If this is the old style "gate" valve there are several things that can clog the line. I would replace it with a 1/4 turn ball valve. That will give you much better flow than a gate valve. You will need to shut down the water probably at the main. The old valve is probably soldered, but you could cut it off and use a compression type valve instead. "Sharkbite" is one such supplier. Although I have never used their compression valve, I have used their end caps and found them to work well.

enter image description here

If you can have someone hold a bucket under the pipe once you cut off the valve and then a second person turns on the water main to fill the bucket to purge the line of any debris. With cast iron pipes it is common to get clogs from rust build up. The rust may not pass the small opening in the old gate valve when you first purged the line.. Although you did not mention what type of pipes you have, if it's copper than you won't normally find rust obstructions..

share|improve this answer
    
I already have a quarter-turn valve, and I'm pretty sure the issue isn't with the supply line. I'm giving you the accepted answer because it helped me realize that since the water gushes out every time just fine if I take the valve head off, that based on your idea, it probably was with the valve. 6 dollars later (plus 10 more on other tools that I ended up not needing, 5 hours of swearing and crying, and 6 more on a second refill kit that took 5 minutes to install thanks to all I had learned the day before) and it's refilling great. Got another slight issue, will post as new question. –  Anthony May 11 '12 at 9:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.