Take the 2-minute tour ×
Home Improvement Stack Exchange is a question and answer site for contractors and serious DIYers. It's 100% free, no registration required.

My fridge (10 year old Elextrolux model PLHT219TCK0) is not cooling (60 degrees) while the freezer works fine. I thawed the freezer for 12 hours and when I turned it back on everything worked fine for a week and then the problem re-appeared. When I opened up the back of the freezer there is a build up of frost on all components. I am thinking that maybe the defroster is not working. See the attached pictures. enter image description hereenter image description hereenter image description here

share|improve this question
add comment

1 Answer 1

Usually there's a fan that moves air from the freezer to the fridge. It could be that the frost is preventing the fan from spinning and/or blocking the air chase between the two. Would probably take a week or so to build up to that point. If the defrosters not working, which, if that's the back of the interior of your freezer, it looks like it isn't, that's definitely what I would start checking.

I'm not fridge guy, but my first step would be to verify voltage to the defroster.

share|improve this answer
    
The fan in the freezer was working/spinning and the vent hole to fridge was not frozen over (middle picture). I am assuming that the amount of frost was not allowing air to properly circulate to the vent opening? And that is why no cold air was getting into the fridge? –  Milos Petrovic Jan 26 '12 at 12:16
    
I had a fridge where the noticeable problem was extreme frost buildup on the coils, and the fix was replacing the fan (which still spun, but slowly and noisily). Perhaps your fan is not moving enough air? –  Kevin Reid Jan 26 '12 at 14:19
    
Where is the fan located relative to the defroster and vent opening? Kevin's suggestion that the fan is under performing seems like a good place to start. Maybe more pictures after you've taken it further apart/let it defrost more would help. –  Erikest Jan 26 '12 at 21:45
    
Frost may also be a sign of low refrigerant levels. if none of the other ideas pan out, you may need to call someone with equipment to test and add if needed. –  TomG Jan 27 '12 at 15:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.